SediFoam安装问题


  • 离散相副教授

    在64核服务器上进行编译SediFoam,进行到了第10步,也就是编译整体的sediFoam,报出了找不到mpi.H以及lmpi的错误。我感觉是不是在单机上安装的,我看了options里面的路径,是不是关于并行这块还要自己根据自己的编译环境更改?报错如下所示:
    -L/home/wangshuai/OpenFOAM/wangshuai-2.3.1/platforms/linux64GccDPOpt/lib -L/home/wangshuai/lammps-1Feb14/src -L/home/wangshuai/lammps-1Feb14/src/STUBS -lLagrangianInterfacialModels -lfiniteVolume -lmeshTools -llagrangian -L/usr/lib64/openmpi/lib/ -lmpi -lmpi_cxx -llammps_shanghailinux -ltriSurface -lchPressureGrad-DEM -lincompressibleTransportModels -lturbulenceModels -lincompressibleTurbulenceModels -llammpsFoamTurbulenceModels -lstdc++ -lOpenFOAM -ldl -lm -o /home/wangshuai/OpenFOAM/wangshuai-2.3.1/platforms/linux64GccDPOpt/bin/lammpsFoam
    /usr/bin/ld: cannot find -lmpi
    collect2: 错误:ld 返回 1
    make: *** [/home/wangshuai/OpenFOAM/wangshuai-2.3.1/platforms/linux64GccDPOpt/bin/lammpsFoam] 错误 1



  • @散漫守望2016 这个是CFDEM下面的求解器?


  • 离散相副教授

    @李东岳 东岳兄,这个是一个基于OpenFOAM和LAMMPS的求解器,有一篇文章叫:Sun_2016_SediFoam A general-purpose, open-source CFD-DEM solver for particle-laden,可以一看。这个求解器其实功能是和CFDEM差不多,也就是求解密相流动的。其不属于CFDEM一部分。


Log in to reply