Ubuntu 18.04LTS能否安装OpenFOAM3.01呢?反过来Ubuntu16.04可否安装OpenFOAM7呢?



  • 因为要用第三方求解器,所以OpenFOAM版本号不能太高。自己又想偶尔用一下高版本的OpenFOAM。

    问题具体为:

    1. 18.04可否实现OpenFOAM3.01和OpenFOAM7呢?
    2. 16.04可否实现呢?

    我现在的问题出错,很郁闷。

    1. 不能使用sudo apt-get -y install openfoam3或者openfoam4,会报错。
    2. 使用官方版的指南安装,由于已经安装了openfoma6(安装方式为sudo apt-get -y install openfoam6),现在安装openfoam3.01,不能编译。不知道怎么解决。

    非常感激!



  • @Hungryandfool 可以在官网上查看两者版本是否相互兼容



  • 已经解决了。谢谢您。可能是自己安装的经验不够吧。


Log in to reply
 

CFD中文网 2016 - 2020 | 京ICP备15017992号-2