关于paraview的问题(Ubuntu17.04)



  • 本人刚刚接触openfoam,安装完成后,第三方软件的parafoam不能编译,每次输入parafoam提示如下错误:(系统是Ubuntu 17.04)
    FATAL ERROR: ParaView reader module libraries do not exist

    Please build the reader module before continuing:
    cd $FOAM_UTILITIES/postProcessing/graphics/PVReaders
    ./Allwclean
    ./Allwmake
    几经折腾还是不行,就通过apt直接下载了paraview5.1.2,可以打开paraview界面了,但不能直接支持读取openfoam的计算结果。。。难道要每次计算后转换成其他格式再用paraview处理吗?
    望各位大神不吝赐教~~


  • OpenFOAM讲师

    编译PVReader需要paraview的头文件,也就是说你的paraview需要是自己编译的才行。

    如果不想自己编译paraview,paraFoam -builtin 先凑合用吧。



  • @wwzhao 谢谢版主,命令可以用来查看了,其实之前自己编译了paraview5.9,但是好像找不到它,启动不了,所以无奈通过apt下载了5.1.2:crying:


  • 管理员

    穿越回来, @ahujeffery 你用的5.9?…


  • Linux讲师

    可以用apt安装的paraview查看。只要在计算结果文件夹创建一个扩展名为foam的空文件就行。touch shocktube.foam。

    在paraview的打开文件窗口找到它

    0_1518060838821_zzzz.png



  • 对,直接在case里面创建一个.foam的空白文档,然后用你下载的paraview找到这个case,打开这个.foam文件,就可以读取你的case了。


  • 管理员

    楼主很前卫,Ubuntu用上了17,paraview用上了5.9 :cheeky: 关键paraview最新版本是5.4 :-)


  • Linux讲师

    应该是正在写“4.9”,心里打着草稿后面要写安装5,然后5就溜出来。。。一边聊天一边写字很容易把说的听的话写出来:confused:


登录后回复
 

与 CFD中文网 的连接断开,我们正在尝试重连,请耐心等待