swak4Foam 和 OpenFOAM4.1



  • 请问大家一个问题,swak4Foam现在是不是不能安装在OF4.1下面?如果能的话能分享一下攻略吗?

    我想用一下swak4Foam,现在已经装好了OF4.1,如果需要在不删除OF4.1的话,可以安装低版本OF(比如OF2.2.2)来用swak4Foam吗?如果这样可以的话,有没有攻略教一下如何同时安装低版本OF?

    谢谢大家



  • 一般新版本OpenFOAM出来之后,其他的外挂包都不能用,都需要原作者做改动的。所以swak4foam很有可能用不了。

    如果要安装多版本OpenFOAM,在bashrc下面设置好环境变量即可,比如这样:

    alias of222="source /opt/openfoam/openfoam222/etc/bashrc"
    alias of4="source /opt/openfoam/openfoam4/etc/bashrc"
    

    每次运行的时候,在终端键入of222则运行openfoam222,of4则运行openfoam4



  • 多谢指点!